LinuxSetup

Home Assignments Lecture Blog Resources Discussion Group

gcc

If you've never done development on your Linux machine before, open the Terminal and do this:

sudo apt-get update
sudo apt-get install build-essential

sfml

  • Ubuntu 14: sudo apt-get install libsfml-dev should give you at least the 2.1 version of SFML.
  • Ubuntu 12: The following will install the 2.0 version of SFML (see http://en.sfml-dev.org/forums/index.php?topic=11338.0 for more info on this distribution):

    sudo apt-add-repository ppa:sonkun/sfml-stable
    sudo apt-get update
    sudo apt-get install libsfml-dev
    

After installation, inspect the file /usr/include/SFML/Config.hpp and look for definitions of SFML_VERSION_MAJOR and SFML_VERSION_MINOR.

Make sure you have at least the 2.0 version!